プログラミング

エラーAn error occurred while installing mysql2 (0.5.3), and Bundler cannot continue. Make sure that `gem install mysql2 -v ‘0.5.3’ –source ‘https://rubygems.org/’` succeeds before bundling.の解決方法

何回も忘れるのでメモ。

原因

Gemfile内にmysql2を書いてない。

解決法

ターミナルで下記を打ち込む。

$ bundle config --local build.mysql2 "--with-ldflags=-L/usr/local/opt/openssl/lib"

Gemfileに下記をかいて、bundle installする。

 

gem 'mysql2', '~>0.5.3'

 

なぐり書き